`
vcdemon
  • 浏览: 19453 次
社区版块
存档分类
最新评论
  • djx410249: 简单的自己想了几个数字测试了下,发现这个数会在经过几次跳动之后 ...
    3n+1
  • I白I: 怎么回事,好多字都卡在外面了 不显示。。。还要查看源代码看内容 ...
    3n+1

The 3n + 1 problem

    博客分类:
  • java
 
阅读更多
The 3n + 1 problem
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 50648   Accepted: 16059

 

Description

Problems in Computer Science are often classified as belonging to a certain class of problems (e.g., NP, Unsolvable, Recursive). In this problem you will be analyzing a property of an algorithm whose classification is not known for all possible inputs. 
Consider the following algorithm: 
 

		1. 		 input n



		2. 		 print n



		3. 		 if n = 1 then STOP



		4. 		 		 if n is odd then   n <-- 3n+1



		5. 		 		 else   n <-- n/2



		6. 		 GOTO 2




Given the input 22, the following sequence of numbers will be printed 22 11 34 17 52 26 13 40 20 10 5 16 8 4 2 1 

It is conjectured that the algorithm above will terminate (when a 1 is printed) for any integral input value. Despite the simplicity of the algorithm, it is unknown whether this conjecture is true. It has been verified, however, for all integers n such that 0 < n < 1,000,000 (and, in fact, for many more numbers than this.) 

Given an input n, it is possible to determine the number of numbers printed before the 1 is printed. For a given n this is called the cycle-length of n. In the example above, the cycle length of 22 is 16. 

For any two numbers i and j you are to determine the maximum cycle length over all numbers between i and j. 


Input

The input will consist of a series of pairs of integers i and j, one pair of integers per line. All integers will be less than 10,000 and greater than 0. 

You should process all pairs of integers and for each pair determine the maximum cycle length over all integers between and including i and j. 

Output

For each pair of input integers i and j you should output i, j, and the maximum cycle length for integers between and including i and j. These three numbers should be separated by at least one space with all three numbers on one line and with one line of output for each line of input. The integers i and j must appear in the output in the same order in which they appeared in the input and should be followed by the maximum cycle length (on the same line).

Sample Input

1 10
100 200
201 210
900 1000

Sample Output

1 10 20
100 200 125
201 210 89
900 1000 174

 

Code:

import java.util.Arrays;  
import java.util.Scanner;  
  
public class Main {  
  
    public static int Test(int n) {  
        int count = 0;  
        if (n == 1) {  
            return 1;  
        }  
        count++;  
        if (n % 2 == 0) {  
            count += Test(n / 2);  
        } else {  
            count += Test(3 * n + 1);  
        }  
        return count;  
    }  
  
    public static void printNum(int m, int n) {  
        int[] temp = new int[2];  
        temp[0] = m < n ? m : n;  
        temp[1] = m > n ? m : n;  
        int[] nums = new int[temp[1] - temp[0] + 1];  
        for (int i = temp[0]; i < temp[1] + 1; i++) {  
            nums[i - temp[0]] = Test(i);  
        }  
        Arrays.sort(nums);  
        System.out.print(m + " " + n + " " + nums[nums.length - 1]+"\n");  
    }  
  
    public static void main(String[] args) {  
        Scanner cin = new Scanner(System.in);  
        while (cin.hasNext()) {  
            String str = cin.nextLine();  
            String[] str0 = str.split(" ");  
            int m = Integer.parseInt(str0[0]);  
            int n = Integer.parseInt(str0[1]);  
            printNum(m, n);  
        }  
        cin.close();  
    }  
}  

 

 

遇到了一个第一次看见的错误:Presentation Error

错误表示 运行结果正确,但是格式错误.

将该删的空格或者换行之类的去掉后就好了.

0
0
分享到:
评论

相关推荐

Global site tag (gtag.js) - Google Analytics